Проблема с восстановлением БД

Что-то не работает? Пишите здесь.

Проблема с восстановлением БД

UNREAD_POST yadzha » 18.11.2009 21:28:02

Всем привет!
Подскажите пожалуйста, пытаюсь восстановить дамп форума, весит 400мб. Использую dumper 1.08. После начала процесса восстановления, через 1 минуту, браузер перестает получать отклик от сервера, браузер перестает грузить страницу и все останавливается без какой-либо ошибки. За это время успевает восстановиться 10-15% от всего объема. Обрезанный дамп на 60мб тогоже форума восстанавливается без проблем. Значит дело в размере БД? Как мне лучше восстановить БД такого объема?
Спасибо.
yadzha
 
Сообщения: 3
Зарегистрирован: 18.11.2009 21:19:57

Re: Проблема с восстановлением БД

UNREAD_POST prosto » 18.11.2009 22:27:02

Можно попробовать поделить на части, например программа HxD Hex Editor очень хорошо справляется с большими файлами.
Или ждать, пока станет готова вторая версия. она вроде как автоматом продолжает восстановку, но пока работает только со своими же файлами.

Ну и еще как вариант, если есть локальный сервер, можно попробовать загрузить бэкап с первым сайпексом, сохранить со вторым, и со вторым восстановить уже на удаленном сервере.
prosto
 
Сообщения: 20
Зарегистрирован: 16.10.2009 02:18:51

Re: Проблема с восстановлением БД

UNREAD_POST yadzha » 18.11.2009 22:33:51

Спасибо за развернутый ответ!
А когда планируется убрать ограничения во 2ой версии дампера на восстановление сторонних БД ? Жду релиза с нетерпением..:)
yadzha
 
Сообщения: 3
Зарегистрирован: 18.11.2009 21:19:57

Re: Проблема с восстановлением БД

UNREAD_POST yadzha » 19.11.2009 18:13:51

Импортировал я дамп на локальной машине dumper'ом 1.08. Далее сделал экспорт базы уже вторым дампером. Почему-то она оказалась почти в 2 раза больше (380МБ - начальный размер, 780 - после экспорта вторым дампером). Это нормально ?
yadzha
 
Сообщения: 3
Зарегистрирован: 18.11.2009 21:19:57

Re: Проблема с восстановлением БД

UNREAD_POST prosto » 19.11.2009 19:48:11

Наверно изначально кодировка была однобайтная, а теперь - UTF-8.
prosto
 
Сообщения: 20
Зарегистрирован: 16.10.2009 02:18:51

Re: Проблема с восстановлением БД

UNREAD_POST zapimir » 23.11.2009 20:12:05

Вы случайно не выбрали во втором дампере кодировку UTF-8? В принципе размер базы в бэкапе должен быть близок к тому сколько дампер показывает в дереве объектов. Бэкап следует делать с кодировкой auto
zapimir
Site Admin
 
Сообщения: 1628
Зарегистрирован: 01.10.2009 22:39:52


Вернуться в Проблемы и баги

Кто сейчас на конференции

Сейчас этот форум просматривают: Bing [Bot], SemrushBot и гости: 9

Яндекс.Метрика