Проблема с запуском Cron

Что-то не работает? Пишите здесь.

Проблема с запуском Cron

UNREAD_POST Alexander01 » 06.12.2015 11:13:33

Доброго дня.
Помогите пожалуйста разобраться, что я делаю не так.

Хостинг Агава, PHP 5.3.
Из панели управлени cPanel пытаюсь настроить запуск кроном
/usr/bin/php -q /home/ЛОГИН/public_html/САЙТ/sxd/index.php -j=НАЗВАНИЕ_ЗАДАНИЯ

в ответ приходить HTML код:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<title>Sypex Dumper 2.0.11</title>
<link rel="shortcut icon" href="load.php?favicon.v208.ico">
<link rel="stylesheet" type="text/css" href="load.php?sxd.v208.css">
</head>
<body>
<div class="dialog" id="dia_auth">
<div class="header"><a href="http://sypex.net/">Sypex Dumper 2.0.11</a></div>
<div class="content" id="div_1" style="line-height:50px;text-align:center;">JavaScript ������������ �������� ��������������</div>
<div class="content" id="div_2" style="display:none;">
<form method="post">
<table cellspacing="5">
и т.д.

То же самое через SSH прекрасно работает (создается рк бд), а если эту строку добавляю в задание Cron получаю HTML код.
Последний раз редактировалось Alexander01 06.12.2015 14:54:25, всего редактировалось 2 раз(а).
Alexander01
 
Сообщения: 2
Зарегистрирован: 06.12.2015 11:03:33

Re: Проблема с запуском Cron

UNREAD_POST Alexander01 » 06.12.2015 13:09:54

Решил проблему добавлением cli

Теперь строка выглядит так:
/usr/bin/php-cli -q /home/ЛОГИН/public_html/САЙТ/sxd/index.php -j=НАЗВАНИЕ_ЗАДАНИЯ

всё работает.
Alexander01
 
Сообщения: 2
Зарегистрирован: 06.12.2015 11:03:33


Вернуться в Проблемы и баги

Кто сейчас на конференции

Сейчас этот форум просматривают: Google [Bot] и гости: 12

Яндекс.Метрика