запуск из под крона

Что-то не работает? Пишите здесь.

запуск из под крона

UNREAD_POST iso20000 » 23.01.2015 18:33:38

проблемы с запуском из под крона
пишет
настроен робот
/usr/bin/php /home/p/public_html/forum/sxd1975/index.php -j=Backup_pnt

X-Powered-By: PHP/5.3.23
Expires: Wed, 19 Nov 2008 19:19:19 GMT
Cache-Control: no-store, no-cache, must-revalidate
Content-Type: text/html; charset=utf-8

Auth error

в связи с этим вопрос по полям в файле конфига что есть что ?

'my_host' => 'mysqlserver',
'my_port' => '3306',
'my_user' => 'pr_admin',
'my_pass' => 'ХХХ',
'my_comp' => 0,
'my_db' => 'pravonat_xf',
'auth' => 'mysql cfg',
'user' => 'pr_admin',
'pass' => 'ХХХ',

для чего
user, pass и my_user, my_pass

?
iso20000
 
Сообщения: 3
Зарегистрирован: 23.01.2015 18:21:41

Re: запуск из под крона

UNREAD_POST zapimir » 23.01.2015 22:25:06

user и pass заполнять не нужно, они нужны для авторизации на базе конфиг-файла. Вы пробовали запускать сохраненную задачу из web-интерфейса, работает?
zapimir
Site Admin
 
Сообщения: 1628
Зарегистрирован: 01.10.2009 22:39:52

Re: запуск из под крона

UNREAD_POST iso20000 » 23.01.2015 22:40:18

да из интерфейса с теми же реквизитами запускаю туже задачу и все работает
более тогго джоб он находит и на него не ругается ошибка при

$auth = $this->connect();

if($auth) echo 'Auth OK'; else echo 'Auth BAD' ;

выводит Auth BAD
пытаюсь вывести ошибку в какой код добавить после
$auth = $this->connect();
что бы прислать ошибку ?
причем рядом работает форум на XenForo и без проблем под тем же юзером к тойже базе коннектится
iso20000
 
Сообщения: 3
Зарегистрирован: 23.01.2015 18:21:41


Вернуться в Проблемы и баги

Кто сейчас на конференции

Сейчас этот форум просматривают: Google [Bot] и гости: 12

Яндекс.Метрика